Pete's Packet

Limitless

  • Catagories

  • Global visitors

    free counters
  • RSS CCIE Jobs – Metro NY area

    • Senior Network Engineer
      CyberCoders New York, NYJob description: ...WAN/LAN and transport technologies, Network Design, Network Automation, Cisco IOS / NXOS / NetScreen / JunOS, Routing Protocols, Unix/Linux, CCIE Preferred, Finance background preferredIf you are a Senior Network Engineer with 5+ years of experience, please read...
    • Unified Communications/VoIP Engineer
      Keshav Consulting Morristown, NJJob description: ...Network Operations CenterLocation - Morristown, NJSalary - 100-150k+ Certifications desired - CCIE My client currently has openings for UC Engineers in their Network Operations Center (NOC)....
    • Network Engineer - Support Wireless Security (LAN / WAN / VPN),
      CyberCoders New York, NYJob description: Minimum Required Skills:Support Wireless Security (LAN / WAN / VPN), CCIE / CCNA / CCNP, Cisco Routers/Switches, TCP/IP, OSIIf you are a Network Engineer with experience, please read on!!Position: Full TimeTitle: Network...
    • Senior Firewall Engineer - Cisco
      CyberCoders New York, NYJob description: ...company and can truly address any challenges they faced. We have a Cisco environment and if you have your CCIE certification that is a huge plus! We are looking for someone with experience in security products and expert knowledge of...

kilobyte to yottabyte

Posted by Peter Kurdziel on October 26, 2015

Value Metric
1000 kB kilobyte
10002 MB megabyte
10003 GB gigabyte
10004 TB terabyte
10005 PB petabyte
10006 EB exabyte
10007 ZB zettabyte
10008 YB yottabyte

Posted in Routing & Switching Lab | Leave a Comment »

Cloud Service and Deployment Models

Posted by Peter Kurdziel on October 12, 2015

Cloud computing is a model for enabling convenient, on-demand network access to a shared pool of configurable computing resources (e.g., networks, servers, storage, applications, and services) that can be rapidly provisioned and released with minimal management effort or service provider interaction. This cloud model promotes availability and is composed of five essential characteristics (On-demand self-service, Broad network access, Resource pooling, Rapid elasticity, Measured Service); three service models (Cloud Software as a Service (SaaS), Cloud Platform as a Service (PaaS), Cloud Infrastructure as a Service (IaaS)); and, four deployment models (Private cloud, Community cloud, Public cloud, Hybrid cloud). Key enabling technologies include: fast wide-area networks,  powerful, inexpensive server computers, and (3) high-performance virtualization for commodity hardware.

The Cloud Computing model offers the promise of massive cost savings combined with increased IT agility. It is considered critical that government and industry begin adoption of this technology in response to difficult economic constraints.

CLOUD SERVICE MODELS

  • Infrastructure as a service (IaaS) provides users with processing, storage, networks, and other computing infrastructure resources. The user does not manage or control the infrastructure, but has control over operating systems, applications, and programming frameworks.
  • Platform as a service (PaaS) enables users to deploy applications developed using specified programming languages or frameworks and tools on the cloud infrastructure. The user does not manage or control the underlying infrastructure, but has control over deployed applications.
  • Software as a service (SaaS) enables users to access applications running on a cloud infrastructure from various end-user devices (generally through a web browser). The user does not manage or control the underlying cloud infrastructure or individual application capabilities other than through limited user specific application settings.

CLOUD DEPLOYMENT MODELS

  • Private clouds are operated solely for one organization. They may be managed by the organization itself or by a third party, and they may exist on or off premises.
  • Public clouds are open to the general public or to a large industry group and are owned and managed by a cloud service provider.
  • Hybrid clouds combine two or more clouds (private or public) that remain unique entities but are bound together by technology that enables data and application portability.
  • Community clouds have infrastructure that is shared by several organizations and supports a specific community. They may be managed by the organizations or a third party and may exist on or off premises.

Five Steps to Building a Private Cloud

  • Standardization
  • Consolidation
  • Virtualization
  • Automation
  • Orchestration

Posted in Cloud | Tagged: | Leave a Comment »

Cisco Nexus FabricPath

Posted by Peter Kurdziel on January 7, 2015

Guidelines and Limitations for FabricPath Switching

FabricPath switching has the following configuration guidelines and limitations:

  • FabricPath interfaces carry only FabricPath-encapsulated traffic.
  • You enable FabricPath on each device before you can view or access the commands. Enter the feature-set fabricpath command to enable FabricPath on each device. See Configuring Feature-Set for FabricPath for complete information on installing and enabling the FabricPath feature set. 
  • The FabricPath feature set operation might cause the standby supervisor to reload if it is in an unstable state, such as following a service failure or powering up.
  • STP does not run inside a FabricPath network.
  • The F Series modules do not support multiple SPAN destination ports or virtual SPAN. If a port on an F Series module is in a VDC and that VDC has multiple SPAN destination ports, that SPAN session is not brought up.
  • The following guidelines apply to private VLAN configuration when you are running FabricPath:
  • All VLANs in a private VLAN must be in the same VLAN mode; either CE or FabricPath. If you attempt to put different types of VLANs into a private VLAN, these VLANs will not be active in the private VLAN. The system remembers the configurations, and if you change the VLAN mode later, that VLAN becomes active in the specified private VLAN.

     

  • FabricPath ports cannot be put into a private VLAN.

     

  • The system does not support hierarchical static MAC addresses. That is, you cannot configure static FabricPath ODAs or OSAs; you can only configure CE static MAC addresses.

  • On the F Series modules, user-configured static MAC addresses are programmed on all forwarding engines (FEs) that have ports in that VLAN.
  • A maximum of 128 switch IDs can be supported in a FabricPath network.
  • FabricPath does not support VTP when in the same VDC. You must disable VTP when the FabricPath feature set is enabled on the VDC.
  • On an F1 series Module, when you configure a port as a FabricPath (FP) core port, and a Classical Ethernet (CE) port exists on the same forwarding engine (FE) instance, MAC address learning behavior for the CE port is affected and this could result in unicast flooding. Therefore, we recommend isolation of CE and FP ports on separate ASIC instances.

 

To configure FabricPath switching, follow these steps:

Step 1: Enable FabricPath on all the devices.
switch# configure terminal
switch(config)# feature-set fabricpath
switch(config)#

Step 2 (Optional): Configure MAC address learning mode.
switch(config)# mac address learning-mode conversational vlan 1-10
switch(config)# show mac address-table learning-mode
switch(config)# exit

Step 3 (Optional): Manually configure a switch ID for the FabricPath device.
switch# configure terminal
switch(config)# fabricpath switch-id 25
switch(config)#

Step 4: Save the configuration.
switch(config)# save running-config startup-config
switch(config)#

Configuration Example for FabricPath Interface

To configure FabricPath interfaces, perform the following tasks on each device:
Enable FabricPath on each device.
Configure the interfaces that you want to designate as FabricPath interfaces.
Set the STP priority device to 8192 on all FabricPath Layer 2 gateway devices.
(Optional) Set the STP domain ID for each of the separate STP domains that are connected to the FabricPath network.
(Optional) Configure a vPC+ switch ID.

To configure FabricPath interfaces, follow these steps:

Step 1 (Optional): Enable FabricPath on each device.
switch# configure terminal
switch(config)# feature fabricpath
switch(config-lldp)# exit
switch(config)#

Step 2: After you enable FabricPath on the device, configure the specified interface as FabricPath interfaces.
switch(config)# interface ethernet 1/2
switch(config-if)# switchport mode fabricpath
switch(config-if)# exit
switch(config)#

Step 3: Configure the STP priority for all Rapid PVST+ VLANs as 8192.
switch# configure terminal
switch(config)# spanning-tree vlan 11-20 priority 8192
switch(config)#

Step 4: Configure the STP priority for all MST instances as 8192.
switch# configure terminal
switch(config)# spanning-tree mst 1-5 priority 8192
switch(config)#

Step 5 (Optional): Configure the STP domain ID on each FabricPath Layer 2 gateway switch attached to the FabricPath network.
switch# configure terminal
switch(config)# spanning-tree domain 5
switch(config)

Step 6 (Optional): Configure the vPC+ switch ID.
switch# configure terminal
switch(config)# vpc domain 5
switch(config-vpc-domain)# fabricpath switch-id 100
switch(config-vpc-domain)# exit
switch(config)

If you are configuring the vPC+ with no existing vPC+, follow these steps:
In the vPC domain configuration mode, enter the fabricpath switch-id switch-id command.
On each of the vPC+ peer link interfaces in interface configuration mode, enter the switchport mode fabricpath command.
On each vPC+ peer link port channel, enter the vpc peer-link command.

If you are changing an existing vPC configuration to a vPC+ on an F Series module, follow these steps:
On each vPC peer link port channel, enter the shutdown command.

In the vPC domain configuration mode, enter the fabricpath switch-id switch-id command.
On each of the vPC+ peer link interfaces in interface configuration mode, enter the switchport mode fabricpath command.
On each vPC+ peer link port channel, enter the no shutdown command.

Step 7: Save the configuration.
switch(config)# save running-config startup-config
switch(config)#

When you are configuring vPC+, and you see the following situations, you must enter the shutdown command and then the no shutdown command on all the peer-link interfaces:
There is no switchport mode FabricPath configuration on the peer-link interfaces, but the FabricPath switch ID is configured in the vPC domain.
The switchport mode fabricpath configuration is on the peer-link interfaces, but there is no FabricPath switch ID in the vPC domain.

Configuration Example for FabricPath Forwarding

To configure the basic FabricPath network with a default topology, you must accomplish the following tasks on each device after you have configured the FabricPath interfaces:
Enable the FabricPath feature set on each device.
Configure the FabricPath interfaces. (See “Configuring FabricPath Interfaces,” for information about configuring FabricPath interfaces.)
Configure the FP VLANs. The default is CE VLANs.
Enter the show running-config fabricpath command to make sure that your FabricPath configuration is correct.

To configure the default FabricPath topology, follow these steps:

Step 1: Enable the FabricPath feature set.
switch# configure terminal
switch(config)# feature-set fabricpath
switch(config)#

Step 2: Set the VLAN modes for those VLANs that you want in the FabricPath topology to FP.
switch# configure terminal
switch(config)# vlan 11-20
switch(config-vlan)# mode fabricpath
switch(config-vlan)# exit
switch(config)

Step 3: Display the configuration to ensure that you have the correct configuration.
switch(config)# show running-config fabricpath
switch(config)#

Step 4: Save the configuration.
switch(config)# save running-config startup-config
switch(config)#

 

 

 

 

 

Posted in Cisco Nexus, Data Center, Nexus, NX-OS | Leave a Comment »

SDN and NFV vendors

Posted by Peter Kurdziel on May 16, 2014

sdn and nfv vendors

Posted in SDN, Virtualization | Leave a Comment »

SDN Technologies

Posted by Peter Kurdziel on May 16, 2014

SDN Technoligies

Posted in Virtualization | Tagged: , , , , , | Leave a Comment »

Nexus 7k configuration limites for OTV

Posted by Peter Kurdziel on May 15, 2014

Configuration Limits for OTV

 

 
Parameter Verified Limit (Cisco NX-OS 6.2) Verified Limit (Cisco NX-OS 6.1) Verified Limit (Cisco NX-OS 6.0) Verified Limit (Cisco NX-OS 5.2)
Number of extended VLANs per system across all configured overlays 1500 256 256 256
Number of total MAC addresses across all sites 32,000 16,000 16,000 16,000
Number of local MAC addresses per site 12,000 8,000 8,000 8,000
Number of edge devices per site 2 2 2 2
Number of OTV-connected sites 8 6 6 6
Number of OTV overlays (simultaneous) 10 10 10 10
Number of instances (instance-id) 1 1 1 1
Number of local multicast routes 4000 2000 2000 2000
Number of multicast data groups 256 256 256 256
Number of secondary IP addresses used for OTV traffic depolarization 3 from Cisco NX-OS Release 6.2(6) N/A N/A N/A

Posted in Nexus, Real World | Tagged: , , | Leave a Comment »

Software-Defined Networking (SDN)

Posted by Peter Kurdziel on May 12, 2014

Software-defined Networking (SDN) is a new approach to designing, building and managing networks. The basic concept is that SDN separates the network’s control (brains) and forwarding (muscle) planes to make it easier to optimize each.

In this environment, a Controller acts as the “brains,” providing an abstract, centralized view of the overall network. Through the Controller, network administrators can quickly and easily make and push out decisions on how the underlying systems (switches, routers) of the forwarding plane will handle the traffic.  The most common protocol used in SDN networks to facilitate the communication between the Controller (called the Southbound API) and the switches is currently OpenFlow.

An SDN environment also uses open, application programmatic interfaces (APIs) to support all the services and applications running over the network. These APIs, commonly called Northbound APIs, facilitate innovation and enable efficient service orchestration and automation.  As a result, SDN enables a network administrator to shape traffic and deploy services to address changing business needs, without having to touch each individual switch or router in the forwarding plane.

The Benefits of SDN

With a centralized, programmable network that can automatically and dynamically address changing requirements, SDN can:

  • Reduce CapEx: reducing the need to purchase purpose-built, ASIC-based networking hardware and supporting pay-as-you-grow models to eliminate wasteful overprovisioning.
  • Reduce OpEX: enabling algorithm control of the network, through network elements that are increasingly programmable, that makes it easier to design, deploy, manage and scale networks. The ability to automate provisioning and orchestration not only reduces overall management time, but also the chance for human error to optimize service availability and reliability.
  • Deliver Agility and Flexibility: helping organizations rapidly deploy new applications, services and infrastructure to quickly meet their changing business goals and objectives.
  • Enable Innovation: enabling organizations to create new types of applications, services and business models that can create new revenue streams and more value from the network

 

 

Posted in SDN | Tagged: , , | Leave a Comment »

Verifying Connectivity Between MPLS VPN Sites

Posted by Peter Kurdziel on March 13, 2014

Verifying IP Connectivity from CE Device to CE Device Across the MPLS Core

1. enable
2. ping [protocol] {host-name | system-address}
3. trace [protocol] [destination]
4. show ip route [ip-address [mask] [longer-prefixes]] | protocol [process-id]] | [list [access-list-name | access-list-number]

Verifying That the Local and Remote CE Devices Are in the PE Routing Table

SUMMARY STEPS

1. enable
2. show ip route vrf vrf-name [prefix]
3. show ip cef vrf vrf-name [ip-prefix]

Posted in BGP, MPLS, VPN | Leave a Comment »

Configuring an MPLS Virtual Private Network Using BGP

Posted by Peter Kurdziel on March 13, 2014

Configuring an MPLS Virtual Private Network Using BGP
======================
PE Config
======================

ip vrf vpn1
rd 100:1
route-target export 100:1
route-target import 100:1
!
ip cef
mpls ldp router-id Loopback0 force
mpls label protocol ldp
!
interface Loopback0
ip address 10.0.0.1 255.255.255.255
!
interface FastEthernet0/0/0
ip vrf forwarding vpn1
ip address 192.0.2.3 255.255.255.0
no cdp enable
!
interface FastEthernet1/1/0
ip address 192.0.2.2 255.255.255.0
mpls label protocol ldp
mpls ip
!
router ospf 100
network 10.0.0. 0.0.0.0 area 100
network 192.0.2.1 255.255.255.0 area 100
!
router bgp 100
no synchronization
bgp log-neighbor changes
neighbor 10.0.0.3 remote-as 100
neighbor 10.0.0.3 update-source Loopback0
no auto-summary
!
address-family vpnv4
neighbor 10.0.0.3 activate
neighbor 10.0.0.3 send-community extended
bgp scan-time import 5
exit-address-family
!
address-family ipv4 vrf vpn1
redistribute connected
neighbor 198.51.100.1 remote-as 200
neighbor 198.51.100.1 activate
neighbor 198.51.100.1 as-override
neighbor 198.51.100.1 advertisement-interval 5
no auto-summary
no synchronization
exit-address-family

============================
CE Config
============================

ip cef
mpls ldp router-id Loopback0 force
mpls label protocol ldp
!
interface Loopback0
ip address 10.0.0.9 255.255.255.255
!
interface FastEthernet0/0
ip address 198.51.100.1 255.255.255.0
no cdp enable
!
router bgp 200
bgp log-neighbor-changes
neighbor 198.51.100.2 remote-as 100
!
address-family ipv4
redistribute connected
neighbor 198.51.100.2 activate
neighbor 198.51.100.2 advertisement-interval 5
no auto-summary
no synchronization
exit-address-family

Posted in BGP, MPLS, VPN | Leave a Comment »

Happy New Year!!!

Posted by Peter Kurdziel on January 8, 2014

Happy New Year

Posted in Routing & Switching Lab | Leave a Comment »